Import OSM-file causes error: java.lang.IllegalStateException: graph is empty after in-place removal

Hello. I tried to import a osm file of this region right here:

but when i try to import the .osm via the i got this:

2016-10-25 17:13:03,613 [main] INFO  com.graphhopper.reader.osm.GraphHopperOSM - using CH|car|RAM_STORE|2D|NoExt|,,,,, memory:totalMB:958, usedMB:25
2016-10-25 17:13:03,753 [main] INFO  com.graphhopper.reader.osm.OSMReader - creating graph. Found nodes (pillar+tower):390, totalMB:958, usedMB:30
2016-10-25 17:13:03,809 [main] INFO  com.graphhopper.reader.osm.OSMReader - 5á623, now parsing ways
2016-10-25 17:13:03,838 [main] INFO  com.graphhopper.reader.osm.OSMReader - 6á099, now parsing relations
2016-10-25 17:13:03,843 [main] INFO  com.graphhopper.reader.osm.OSMReader - finished way processing. nodes: 79, osmIdMap.size:395, osmIdMap:0MB, nodeFlagsMap.size:5, relFlagsMap.size:0, zeroCounter:5 totalMB:958, usedMB:37
2016-10-25 17:13:03,844 [main] INFO  com.graphhopper.reader.osm.OSMReader - time pass1:0s, pass2:0s, total:0s
2016-10-25 17:13:03,845 [main] INFO  com.graphhopper.reader.osm.GraphHopperOSM - start finding subnetworks, totalMB:958, usedMB:37
2016-10-25 17:13:03,853 [main] INFO  com.graphhopper.routing.subnetwork.PrepareRoutingSubnetworks - car findComponents time:0.007008007, size:8
2016-10-25 17:13:03,856 [main] INFO  com.graphhopper.routing.subnetwork.PrepareRoutingSubnetworks - 79 subnetworks found for car, totalMB:958, usedMB:37
2016-10-25 17:13:03,857 [main] INFO  com.graphhopper.routing.subnetwork.PrepareRoutingSubnetworks - optimize to remove subnetworks (79), unvisited-dead-end-nodes (85), maxEdges/node (0)
2016-10-25 17:13:03,858 [main] WARN - More than a half of the network should be removed!? Nodes:79, remove:79
Exception in thread "main" java.lang.IllegalStateException: graph is empty after in-place removal but was 79
        at com.graphhopper.routing.subnetwork.PrepareRoutingSubnetworks.doWork(
        at com.graphhopper.GraphHopper.cleanUp(
        at com.graphhopper.GraphHopper.process(
        at com.graphhopper.GraphHopper.importOrLoad(

what can i do?

Can you please try


in the

See this and this.

1 Like

worked properly.

Thank you very much! :+1:

1 Like