Setup for Flexible / Configurable Weighting Update

I would really like to test the new flexible feature (Flexible / Configurable Weighting Update), but I’m struggling to get it to work.

What do I need to do, to enable it?

I’ve setup graphhopper according to the quick start guide (master branche) https://github.com/graphhopper/graphhopper/blob/master/docs/core/quickstart-from-source.md

Graphhopper is running, but no flex input field on the left side in the UI

I can do POST request, but setting parameters like max_speed doesn’t have any effect on the result.

So I am obviously missing something. Help would be really appreciated.

Did you checkout the special feature branch issue_1776? (It is not yet in master, hopefully it will before 1.0 release)

If you have done this, then you need to rebuild the jar (mvn clean)

I knew it was something stupid. Sorry, should have noticed that. Thanks a lot.

I’ve got it working now. I can make POST requests, save a profile as .yml and use that profile to do GET request with weighting=custom_NAME and ch.disable=true.

What do I need to do, to enable the profiles for CH preparation?

Tested with prepare.ch.weightings=NAME and prepare.ch.weightings=custom_NAME, but I’m only getting “Not a valid name for a Weighting:”

and prepare.ch.weightings=custom_NAME

Did you try lower case characters e.g. custom_truck? See CustomWeightingRouteResourceTest.

Please note that this will be likely changed before the release.

It’s a naming issue.

I named the file car_100.yml initially. No problem with non ch requests with custom_car_100, but apparently ch preparation doesn’t work with underscores or numbers in the file name. Changed it to carhundred.yml and everything is working now.

1 Like
Powered by Discourse