U_turn_costs=5000 doesn't change route, still uses u-turn

https://graphhopper.com/maps/?point=33.335853%2C-111.758895&point=33.315898%2C-111.608906&locale=en-US&vehicle=car&weighting=fastest&elevation=true&turn_costs=true&algorithm=alternative_route&use_miles=false&layer=Omniscale&ch.disable=true&u_turn_costs=5000

In this route, I set u_turn_costs to 5000 to essentially disable u-turns, but it doesn’t affect the route. According to the github doc below, I can choose u_turn_costs by disabling ch:

This is currently not identified as U turn because different edges are used, i.e. this is an open issue.

Pretty amazing how you and some others quickly respond. Thanks! :+1:

1 Like
Powered by Discourse