Timeout in request with restriction zones


I’m trying to process the attached request, note that I have some avoidance areas in my custom model, but I’m receiving a timeout error in 14 seconds.

request-with-avoidance-area.json (209.4 KB)

Is there a way to increase the time before timeout? Or is there something I can do to process this request withuot removing any avoidance area? There will be some cases, that I’ll need to add more. Also is there a limit to avoidance areas in custom model?

The problem are long routes and when using areas and the route deviates too much from the optimum the timeouts can occur. See my answer here: Directions timeout request - #2 by karussell

@karussell, I saw on the other topic that removing custom_model and ch.disable, the route may succeed. But I can follow this option cause one of the avoidance areas is inside the route. Is there another way to route successfully?

PS.: If I remove restriction areas, the route succeed, without removing custom_model and ch.disable. But as I said, I need to provide avoidance area.