The Performance of Map Matching's doWork method is a little low。

I want to know if some friends is using Map-Matching。I wonder it’s low performance, when match a large coordinates。What should I do? I can’t optimize it。

Which version are you using?

1.0-SNAPSHOT. I integrate map-matching source master branch to my app.

Can you try 1.0-pre23, or even 0.13 and check if its faster?

Try it,but not effective。

Can you better describe what you mean with “performance is a little low” and against what you compare that? Also which Java version are you using, how many QPS you have or expect etc.

BTW: you should never use a snapshot except when you know what you are doing.

Ok thanks for trying, did you delete the graph folder as well, so another import was happening?

@karussell I was wondering if this could be due to the fact that we disabled default CH between 1.0-pre23 and 1.0-pre24

For shorter distances without CH should be even faster: https://github.com/graphhopper/map-matching/pull/71#issuecomment-250778348. And without feedback about the exact requirements, versions or GPS file we cannot really say what is going on.

Thanks for your response. I’m using Map-Matching 0.13. Java version: 1.8. Singe Test Now. 1106 coordinates are tested. spending time about 7 seconds.

Details:
1106 coordinates. 221 TimeSteps were builded.
“computeViterbiSequence” spended most time.
“computeTransitionProbabilities” is executed many times, and it runs slowly.
I wonder What’s wrong with me.
Thank you again.

Thank you for your response.
Graph_cache was reimported by myself. “computeTransitionProbabilities” is executed many times.

Details:
1106 coordinates.
“computeTransitionProbabilities” runs 221 times , total time consuming about: 7 seconds

The number of the total TimeStep’s candicates determines the running time.But my test data’s candicates is a great many — 2483. What should I do? Is it a normal performance show? Thank you for helping me.

Powered by Discourse