Skipping points on structure/way type changes

I did map-matching for my track.
Is that known issue, that on junctions of different road structures(bridge in this example) matching algorithm is skipping junction points?

Likely to be the same issue as

You fetch the map matched result via API and the point list is run through douglas peucker algorithm to compress the long list. Can you try way_point_max_distance=0 per request or routing.way_point_max_distance: 0 in the config?


I’m running matching in the following way:

java -jar \m\data\gps\libraries\map-matching-1.0-pre14\matching-web\target\graphhopper-map-matching-web-1.0-SNAPSHOT.jar match \m\data\gps\activities_filtered_by_regions\tatry*.gpx

I know douglas peucker algorithm and WRONG I’m pretty sure, that it is not applied WRONG to the results of my matching. My “problem” occurs only on crossings and road structure changes.

I tried to set those parameters but I’m not sure that I did it correctly. Can you give me example?
Can you take a look at that issue again to check if that is side effect of some actions and can be solved? Actually this may not be considered as the issue for most of users, as it may be not important to include every single point on path to match results, but it is important to my heatmap generation experiments.

I wrote in above post, that douglas peucker algorithm is not applied to matching results. I was wrong. It seems, that that algorithm is used, but with very small threshold.

@karussell is it possible to disable that algorithm?