Setting up Graphhopper on Docker

I am trying to setup graphhopper on windows based docker with Linux containers. I have successfully been able to build docker image using the github docker file and when I try to run it using docker run, it runs successfully as well, with the following messages…

INFO [2018-08-09 09:07:09,076] org.eclipse.jetty.server.handler.ContextHandler: Started i.d.j.MutableServletContextHandler@7e3d7dd{/,null,AVAILABLE}
INFO [2018-08-09 09:07:09,087] org.eclipse.jetty.server.AbstractConnector: Started application@44a6a68e{HTTP/1.1,[http/1.1]}{}
INFO [2018-08-09 09:07:09,089] org.eclipse.jetty.server.AbstractConnector: Started admin@4743a322{HTTP/1.1,[http/1.1]}{localhost:8990}
INFO [2018-08-09 09:07:09,089] org.eclipse.jetty.server.Server: Started @40219ms

How can I access the graphhopper server now. I have tried http://localhost:8990 but of no use.

What am I doing wrong here ? Can someone help ?

It should be on this port for docker. Maybe we change this to the same 8989 port? (on 8990 there is the admin endpoint)

I tried that port as well, using http://localhost:11111 but it did not work either, so it must be another probllem.

The default settings only listen to localhost, but maybe your docker is running on a virtual machine? If you use the DockerToolbox it will be most likely on or similar. I have a docker pull request running for which altered server settings are used.