Routing to Hong Kong only possible with custom model?

just a small question concerning the route planner. A query to find a route to Hong Kong always fails with an error message of ‘Connection between locations not found’.

We are currently using the API to estimate distances and every route containing Hong Kong fails with the same error message and the same happens if I try the same in the UI.
However, if I enable custom mode, it suddenly works (at least with most of the provided examples in the UI).

screenshot removed because of restriction for new users

I’m trying to figure out what the reason for this and if there is a parameter that we should be using in order to make it work?

What are the exact coordinates?

It is likely caused by some private roads or barriers with private access only leading to a disconnected area where you intend to start. Because this is mostly the only difference to the custom mode. And likely the same error will happen if you use the following custom model:

{ "priority": [ {
      "if": "road_access == PRIVATE",
      "multiply_by": "0"

Thanks for pointing this out. I tried it with your example and it could still find a route with this custom model, so it seems to be some other kind of barrier.
Here is the error message I get with the GET method including the coordinates (without custom model)
‘Unable to find a route between points 1 (113.2592945 23.1301964) and 2 (114.1628131 22.2793278)’

Ok, I noticed that it is sufficient to set ch.disabled to true. A custom mode is not required to find a route.

The problem seems to be that entire Hong Kong seems to be disconnected due to inaccessible roads/bridges:

They all have access=no (Will have to investigate why it works with the custom model)

Thanks for the explanations. I’m not sure why this is the case, but I know that our customer uses this route so my goal is to estimate the travelled distance and that’s why I’m fine with using ch.disable, although it might slightly slow down response times, if I understand this correctly.
What I noticed is that with other route planners this route is also not always found. However, on it also seems to ignore the fact, that the bridge are marked as not accessible and it shows me the same route. So it might be interesting to further investigate why this is the case.

Sorry my bad. The hint with the other routing engines was helpful, thanks :slight_smile: !

The tagging access=no is lifted due to motor_vehicle=permit and so our default vehicle profiles don’t allow passing this, only the car_delivery profile does. Can you try it with this profile (without ch.disable)?

I tried it with your example and it could still find a route with this custom model, so it seems to be some other kind of barrier.

This is a bug that we do not yet include permit in the road_access attribute. Will be fixed soonish in our API.

Using one of the delivery profiles does indeed solve the issue, thanks!

1 Like