Routes are not showing in some locations


#1

I cannot route for these places [1.250041,103.846343] and [1.2431999,103.8370791].
Public vehicles can access these places.
When I tried in Editor also, cannot route.
But OpenStreetMap can route these places.
Please check attached image for Editor result.


#2

probably because of Node: 1108854792, which is a lift gate.


#3

Thanks @jie31best

Yeah, It’s probably
When I use Car (Graphhopper) in OpenStreeMap, route cannot pass through this gate as shown in below image.
How could I solve this issue as it is not restricted area for public?


#4

Thanks @jie31best for the debugging :slight_smile: ! @myominlin You could add tagging to make it explicitly allowed like access=yes https://wiki.openstreetmap.org/wiki/Key:access


#5

Thanks @karussell
I will try with tagging, but i don’t know how to do it as I’m most familiar with Optimization API.
No parameters in Routing API.
Could you help me how to add tagging?


#6

The tagging is meant regarding the data. Would you mind editing/adding this at https://www.openstreetmap.org -> click ‘edit’?


#7

I already edited in OpenStreetMap.
This is the changeset I edited.

But, directions in Graphhopper are still not correct as the following image.


#8

This requires an update of the road network on our side, which typically is done every day and can therefor take up to 2 days


#9

@myominlin while waiting for graphhopper to update the road network on their side, you might want to take a look at some other nodes in this area, because there are quite a few barriers like lift gate, gate, etc. in Sentosa. for example:

Node: 367274390
Node: 1110010160
Node: 1660428291
Node: 367326276


#10

Sorry this long update process is not normal and there was an issue, which is now fixed and an update will show up in ~20h :slight_smile:

Regarding the barriers: we created a discussion on OSM about this problem, see here


#11

Thanks @jie31best and @karussell

I will check these two locations tomorrow.
According to OSM discussion, the gate barrier may be different depends on private or public.
So, this issue may have in the future also, right?


#12

Is now updated: https://graphhopper.com/maps/?point=1.250454%2C103.826144&point=1.250041%2C103.846343

BTW: why is the access allowed but not for bikes and horses? http://www.openstreetmap.org/node/1108854792#map=19/1.24785/103.83782


#13

Thanks @karussell

I am not sure for bikes and horses for these places. That’s why, I only changed for vehicles.
I updated other lift_gates in the same island also.
Could you please help me update the following changesets: