Route not found with default settings, but route is found on public instance

First of all: hats off for GraphHopper, impressive work!

I’m experimenting with a local instance using the default settings (config-example.yml) and today’s netherlands-latest.osm.pbf. When routing between the following coordinates: Driving Directions - GraphHopper Maps no route is found on my local instance. But as you can see it does work on the public instance.

I’ve tried tuning the prepare.min_network_size and prepare.min_oneway_network_size - all the way down to value 1 - but without effect. What am I missing?


I just tried this (current master, netherlands-latest.osm.pbf + config-example.yml) and it worked fine. Maybe you forgot deleting the graph-cache folder when you changed some of the configuration or something?

Thanks for testing! I’ll have a look

Well I’ve done some tests and indeed with GraphHopper 7-SNAPSHOT (master) the route is found. With the latest GA release 6.2 the route is not found. I’ve performed both tests in a clean fashion (new graph, same OSM import, no fiddling with settings).

In master config-example.yaml has changed in the sense that now a custom model is used by default for cars. I’ve tried applying the same settings for 6.2 (same profile) but that doesn’t make any difference. So that’s not the cause. Master does produces a larger graph, so I think that results in the route now being found. Would be interesting to know which change in master causes this. But overall, happy to see this route is found. Looks like an improvement!

Yes, I can confirm this. With 6.2 this entire part of the graph seems unreachable:

I’m not sure why, though.

It does not work in 6.2 using default settings because some of these roads are tagged as maxspeed=5, which is then rounded down to speed=0. This was fixed here: improve handling of low speed by karussell · Pull Request #2726 · graphhopper/graphhopper · GitHub

To work around this you could also decrease the speed_factor for the car vehicle.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.