Map-window not shown if ./graphhopper.sh is run

On my virtual machine Ubuntu installation I could at first display the map by calling ./graphhopper.sh as described here right at the beginning of “Try out”. So far so good.

Doing the exact same steps on two more native Ubuntu installations did not work as expected, as no map-window was shown. It’s the same problem as here, but since my installation was pristine, it seems quite weird.

As I don’t need to see the map anyway, it did not bother me so much. However, I ran into some strange problems with my map and would like to inspect it - for which I need the map-window. And now, it does not even show in the installation where it originally worked. Even if I install a clone of graphhopper parallel to it, that new one does not produce the map-window.

I have
/web/target/classes/assets/js/main.js
/web/src/main/resources/assets/js/main.js
but no other “main.js”.

Firefox reports two warnings:

Unfortunately I’m not deep enough into the matter to be able to work out the solution on my own. Many thanks in advance!

Ah, you are right. Now, after https://github.com/graphhopper/graphhopper/pull/1641 the step

cd web
npm install
BROWSERIFYSWAP_ENV='development' npm run bundleProduction

is required. Will add this to the web action.

See also: https://github.com/graphhopper/graphhopper/issues/1700

Have fixed this in master now.

Thanks very much. However, I found that on at least one system (the virtual machine), a simple
./graphhopper clean
solves the problem as well (at least as a workaround on the system which once showed the map). I hope that does not contradict your finding…

Once again, I deeply bow before everyone who contributes to this wonderful software!

See also https://github.com/graphhopper/graphhopper/pull/2041 where we will better fix this.

Thanks!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Powered by Discourse