Map Matching parent will not build

./map-matching.sh action=import datasource=./some-dir/osm-file.pbf vehicle=car

Using this command from the info page, ofc with the right datasource, I get build errors when it tries to build matching-core.
I have tried diffrent versions and haven’t found a working branch. What can I do to solve this?

Oh, this should not be. Will have a look so that current master and 0.10 branch will work

Ok, can you try master or branch 0.10?

Yup I got it to work now. Great! Thank you.

1 Like

running branch 0.8 works fine but with the branch 0.10 or the master:

  • while running ‘mvn package’, it get succesfully tested and build.
  • I run then ./map-matching.sh and get errors:

[ERROR] Failed to execute goal on project graphhopper-map-matching-core: Could not resolve dependencies for project com.graphhopper:graphhopper-map-matching-core:jar:0.10-SNAPSHOT: Failed to collect dependencies at com.graphhopper.external:hmm-lib:jar:0.10-SNAPSHOT: Failed to read artifact descriptor for com.graphhopper.external:hmm-lib:jar:0.10-SNAPSHOT: Could not find artifact com.graphhopper:graphhopper-map-matching-parent:pom:0.10-SNAPSHOT

what can i do about it ?
Kind Regards

For master we have removed the script. Please see the usage here: https://github.com/graphhopper/map-matching#usage

OK. When I run ‘mvn package’ in the latest master

[INFO]
[INFO] — maven-jar-plugin:3.0.2:jar (default-jar) @ hmm-lib —
[INFO] Building jar: /home/routeyou/map-matching/hmm-lib/target/hmm-lib-0.11-SNAPSHOT.jar
[INFO]
[INFO] -----------< com.graphhopper:graphhopper-map-matching-core >------------
[INFO] Building GraphHopper Map Matching 0.11-SNAPSHOT [3/4]
[INFO] --------------------------------[ jar ]---------------------------------
[WARNING] The POM for com.graphhopper:graphhopper-reader-osm:jar:0.11-SNAPSHOT is missing, no dependency information available
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] GraphHopper Map Matching Parent Project 0.11-SNAPSHOT SUCCESS [ 0.295 s]
[INFO] hmm-lib … SUCCESS [ 1.454 s]
[INFO] GraphHopper Map Matching … FAILURE [ 0.024 s]
[INFO] GraphHopper Map Matching Web 0.11-SNAPSHOT … SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.896 s
[INFO] Finished at: 2018-05-23T10:29:22Z
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project graphhopper-map-matching-core: Could not resolve dependencies for project com.graphhopper:graphhopper-map-matching-core:jar:0.11-SNAPSHOT: Could not find artifact com.graphhopper:graphhopper-reader-osm:jar:0.11-SNAPSHOT -> [Help 1]
> [ERROR]

Ah, this might be as we do not yet allow fetching dependencies from the sonatype snapshot repository.

@michaz do you think we should allow this? I would argue against it and one would have to build GH core before map matching (then we would need to update the map matching documentation)

@karussell If by allow you mean putting the snapshot repository into the POM.XML, then yes, we should do it. I was assuming it was already in, since Travis runs through. Perhaps they have a default list of repos hidden somewhere. Which shows that it’s not so much a matter of permission – mainly, the user configures their repositories. The “repository” entry in the POM is a hint, if you will.

(Putting it in.)

@Benjamin_Van_Bever

Okay, I think I got this. With the latest repository version, I just tried building and running it on a pristine Linux server with only Java and Maven installed, and it works. Thanks for asking…

1 Like

Thanks! We should be aware that then snapshots could slip into the dependency hierarchy even for stable builds (I think was the reason it is not already in the pom.xml)