java.lang.IllegalArgumentException: entry in encoder list not supported pt

Following the instructions here: https://github.com/graphhopper/graphhopper/tree/master/reader-gtfs

Got the following error:
java.lang.IllegalArgumentException: entry in encoder list not supported pt
at com.graphhopper.routing.util.DefaultFlagEncoderFactory.createFlagEncoder(DefaultFlagEncoderFactory.java:60)
at com.graphhopper.routing.util.EncodingManager.parseEncoderString(EncodingManager.java:393)
at com.graphhopper.routing.util.EncodingManager$Builder.addAll(EncodingManager.java:190)
at com.graphhopper.GraphHopper.createEncodingManager(GraphHopper.java:587)
at com.graphhopper.GraphHopper.init(GraphHopper.java:532)
at com.graphhopper.http.GraphHopperManaged.(GraphHopperManaged.java:90)
at com.graphhopper.http.GraphHopperBundle.run(GraphHopperBundle.java:200)
at com.graphhopper.http.GraphHopperBundle.run(GraphHopperBundle.java:54)
at io.dropwizard.setup.Bootstrap.run(Bootstrap.java:200)
at io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:42)
at io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:87)
at io.dropwizard.cli.Cli.run(Cli.java:78)
at io.dropwizard.Application.run(Application.java:93)
at com.graphhopper.http.GraphHopperApplication.main(GraphHopperApplication.java:36)

This doesn’t seem to work. I dug into the source code and there isn’t a “pt” type (https://github.com/graphhopper/graphhopper/blob/master/core/src/main/java/com/graphhopper/routing/util/FlagEncoderFactory.java)

Is there something that I’m missing here? Is “pt” flag removed?

Powered by Discourse