Inconsistent results local vs api

Hi there, I downloaded the Scotland road data from the recommended source. Now, I am using the following points:
start: 58.48618,-4.660778
end: 58.501318,-4.656744

When using the web map provided on your website, there is a route there directly:

But when using 2.3 stable branch locally I am routed around like so:

I am using a fresh install of the stable branch on an Ubuntu machine. Why are the results different? How could one go about debugging this difference?

Thanks in advance

Can you try to run a new import locally and add foot or bike encoders as well? Make sure to delete the xyz-gh folder to run a new import. Do you get the same big detour for the foot profile as well? Next thing you can do is open the layers menu in the web UI (the layers icon shown on the top right of the map) and enable ‘local MVT’. This will render GraphHopper’s road network. Can you see road segments between your two points? Also you will see some details about the roads when you touch them with your cursor. Are your points close to the border/bounding box of the map?

Thanks for your prompt reply easbar. I tested using foot and bike vehicle profiles can confirm this only happens when using the car profile. I originally noticed this with a motorcycle profile but I realise it inherits car.

Below is a screenshot from local MVT. Not sure how to read it exactly but clicking on either sides of the detour I see the same road data. Looking at the OSM data, the detour seems to happen because GH isn’t using a way that turns from a one lane to a two lane. Neither of them are marked as one way however.

This is not a set of points near the edges of the imported area and also happened with a Europe dataset.

I also tried playing with the prepare.min_network_size paramter setting it to 10 and 300 with no impact on this route.

Maybe a node with a ford or barrier tag? The default behavior is to block access if not explicitly allowed.

A ha! Thanks, you pointed me in the right direction. There seems to be a cattle grid in the location that’s causing problems. Surely car traffic should be allowed to go though cattle grids by default? I’m guessing I’ll have to adapt the profile manually to allow for this behaviour.

Powered by Discourse