How to activate the shortest weighting?

Hi
I’m trying to run activate Graphhopper with “shortest” weighting with no luck.
What am I do wrong?

This is original request with fastest weighting
https://graphhopper.com/maps/?point=51.514885%2C-0.143766&point=51.51769%2C-0.119519&locale=en-US&vehicle=foot&weighting=fastest&elevation=true&layer=Omniscale

but when I change the weighting to shortest I get server error
https://graphhopper.com/maps/?point=51.514885%2C-0.143766&point=51.51769%2C-0.119519&locale=en-US&vehicle=foot&weighting=shortest&elevation=true&layer=Omniscale

Thanks,
Eli

Hi Eli,

the hosted GraphHopper Maps (and the Directions API) currently only support fastest. If you run your own server you can use both if you disabled CH. If you need CH specify prepare.chWeighting=shortest or if you run the latest master you can also use both: prepare.chWeighting=fastest, shortest

The route itself looks suspicious and off-the-list you said Oxford Street is tagged sidewalk=both or left|right which I can confirm and so it should not be avoided that much, probably. Would you raise an issue on github for this?

Peter

Thanks Peter
I open a githug issue https://github.com/graphhopper/graphhopper/issues/633
Eli

1 Like