Graphoopper installation

Good morning all,
I installed graphhopper under ubuntu while when I type in the browser: http: // localhost: 8989 it always displays me as berlin study area while I am working on Algeria and despite what I specified in the following command to start graphhopper: java -Ddw.graphhopper.datareader.file = algeria-latest.osm.pbf -jar * .jar server config-example.yml
what I am looking for now is when I type http: // localhost: 8989 in the browser I will display Algeria
thanks for the help in advance

This sounds like you first started GH for the Berlin area and then you changed datareader.file to Algeria, but you did not delete the graph-cache folder. You need to delete this folder and start it again so the Algeria data is imported. You can also use -Ddw.graphhopper.graph.location=algeria-gh which will also lead to a fresh import and the data will be stored in algeria-gh instead of graph-cache.

1 Like

Good morning all,
thank you for answering me mister essbar, when I typed the command line you sent me : -Ddw.graphhopper.graph.location=algeria-gh
it shows me the following message: Ddw.graphhopper.graph.location=algeria-gh : command not found

what can i do now

The complete command should be

java -Ddw.graphhopper.datareader.file=algeria-latest.osm.pbf -Ddw.graphhopper.graph.location=algeria-gh -jar *.jar server config-example.yml

The -Ddw.graphhopper.graph.location=algeria-gh part is just setting the folder where GraphHopper saves it’s data. Did you try to delete the graph-cache folder? This might be easier for you and you can use your original command.

I have not tried because I do not have the command used to delete the “graph-cach” file can you help me in this regard

Maybe you should learn some Ubuntu basics first then? Are you working on a server remotely or do you use a graphical user interface?

I use a graphical user interface?

Ok so just find out how to delete a folder and remove the graph-cache folder.

it seems to me that it is solved I entered in the file config-example.yml and in the line graph.location: graph-cache I replaced graph-cach by: “” and save this file under another name config for example then I typed the command line java -Ddw.graphhopper.datareader.file = algeria-latest.osm.pbf -jar * .jar server config-example.yml
when i typed http: // localhost: 8989 in the browser i got the display of algeria border

Ok :slight_smile: I’m glad you got it working.

thank you my brother good luck.

Powered by Discourse