GraphHopper Script error

Hi everyone,

I’m currently working on my master thesis and I’m evaluating tools in order to see which suits the best to my need. I got an issue with the that is provide in the repo. When I run it with good parameters everything goes well until it try the “web part”

In fact it dl the data correctly from geofabrik and then :

## now web. JAVA_OPTS=-Xmx1000m -Xms1000m
INFO  [2019-02-07 11:02:00,725] io.dropwizard.server.DefaultServerFactory: Registering jersey handler with root path prefix: /
INFO  [2019-02-07 11:02:00,730] io.dropwizard.server.DefaultServerFactory: Registering admin handler with root path prefix: /
java.lang.IllegalArgumentException: No enum constant
        at java.lang.Enum.valueOf(
        at com.graphhopper.GraphHopper.init(
        at com.graphhopper.http.GraphHopperManaged.<init>(
        at com.graphhopper.http.GraphHopperBundle.runRegularGraphHopper(
        at com.graphhopper.http.GraphHopperApplication.main(

So I checked if it could come from my java version. I have 1.8.0_181 (on the first machine I tested it) and (on the other machine I tested it). I also try to do it on an other machine but I got the same error. I also went through the code to see if I may find a way to correct this but I didn’t find out where does it could come from.

I don’t know if it’s the appropriate place to ask for this kind of help but is this a known error and where could it come from ? What can I do to correct this ?

Thank you a lot in advance for your help,

Best Regards
Arnaud Boissaye

Please use the latest stable 0.11

git checkout 0.11
(rebuild jar & remove graph cache)

Thank you a lot I indeed didn’t thought it could come from there It’s working now. Thanks you


@GarfAbh @VictorGevondyan master should work now too:

cd graphhopper
git pull
./ clean

Yeah, thank You. I also make ./ clean. And it works! :wink::blush:. Thank You a lot! :smiley:

1 Like