Error when trying to run Graphhopper for the first time

Hello. I am new at this application.

I am following the instructions at ‘GraphHopper - Quick Start Guide for Developers’.

But when I run the command ‘./graphhopper.sh -a web -i sudeste-latest.osm.pbf’, I get an error, and I am not able to open http://localhost:8989/.

I have already searched other topics on this forum, but I couldn’t find any error similar to this one.

Could you please give me any advices?

Follow the message:

$ ./graphhopper.sh -a web -i sudeste-latest.osm.pbf

using java 1.8.0_241 (64bit) from

./graphhopper.sh: linha 138: mvn: comando não encontrado

using existing osm file sudeste-latest.osm.pbf

building graphhopper jar: web/target/graphhopper-web-0.13-SNAPSHOT.jar

using maven at ./maven

compilation of parent failed

[INFO] Scanning for projects…
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Build Order:
[INFO]
[INFO] GraphHopper Parent Project
[INFO] GraphHopper API
[INFO] GraphHopper Web API
[INFO] GraphHopper Core
[INFO] GraphHopper Reader for OpenStreetMap Data
[INFO] GraphHopper Isochrone
[INFO] GraphHopper Reader for Gtfs Data
[INFO] GraphHopper Directions API hand-crafted Java Client.
[INFO] GraphHopper Dropwizard Bundle
[INFO] GraphHopper Web
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building GraphHopper Parent Project 0.13-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building GraphHopper API 0.13-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] — maven-resources-plugin:2.6:resources (default-resources) @ graphhopper-api —
[INFO] Using ‘UTF-8’ encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory C:\cygwin64\home\Avelino\graphhopper\graphhopper\api\src\main\resources
[INFO]
[INFO] — maven-compiler-plugin:3.8.1:compile (default-compile) @ graphhopper-api —
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 43 source files to C:\cygwin64\home\Avelino\graphhopper\graphhopper\api\target\classes
[WARNING] Unable to autodetect ‘javac’ path, using ‘javac’ from the environment.
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] GraphHopper Parent Project … SUCCESS [ 0.078 s]
[INFO] GraphHopper Web API … SKIPPED
[INFO] GraphHopper Core … SKIPPED
[INFO] GraphHopper Reader for OpenStreetMap Data … SKIPPED
[INFO] GraphHopper Isochrone … SKIPPED
[INFO] GraphHopper Reader for Gtfs Data … SKIPPED
[INFO] GraphHopper Directions API hand-crafted Java Client. SKIPPED
[INFO] GraphHopper Dropwizard Bundle … SKIPPED
[INFO] GraphHopper Web … SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.700 s
[INFO] Finished at: 2020-02-22T12:48:11-03:00
[INFO] Final Memory: 11M/164M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile (default-compile) on project graphhopper-api: Compilation failure -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR] mvn -rf :graphhopper-api

Thanks in advance.

renato

Can you try to set your java environment variable location within the system path and ensure you have installed your Java SDK?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Powered by Discourse