Error after change data

I change data of my map. Because I need enable turn restrictions
In config there is changes:

graph.flag_encoders: car|turn_costs=true
turn_costs: true

Then if I send

/match?vehicle=car&gps_accuracy=40&type=json&max_visited_nodes=50000&points_encoded=false

<?xml version="1.0" encoding="UTF-8"?><gpx xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="1.0" xmlns="http://www.topografix.com/GPX/1/0" creator="Polar WebSync 2.3 - www.polar.fi" xsi:schemaLocation="http://www.topografix.com/GPX/1/0 http://www.topografix.com/GPX/1/0/gpx.xsd"><trk><name>GPX-file</name><trkseg><trkpt lat="49.956123" lon="82.617107"></trkpt><trkpt lat="49.956058" lon="82.616886"></trkpt><trkpt lat="49.956438" lon="82.616912"></trkpt><trkpt lat="49.955023" lon="82.61512"></trkpt><trkpt lat="49.954658" lon="82.612628"></trkpt><trkpt lat="49.954782" lon="82.612487"></trkpt><trkpt lat="49.955468" lon="82.613802"></trkpt><trkpt lat="49.953476" lon="82.616253"></trkpt><trkpt lat="49.952372" lon="82.616557"></trkpt><trkpt lat="49.95123" lon="82.615548"></trkpt><trkpt lat="49.9512" lon="82.615344"></trkpt><trkpt lat="49.947573" lon="82.617955"></trkpt><trkpt lat="49.943719" lon="82.621075"></trkpt><trkpt lat="49.942068" lon="82.622472"></trkpt><trkpt lat="49.928316" lon="82.619782"></trkpt><trkpt lat="49.918978" lon="82.625142"></trkpt><trkpt lat="49.918274" lon="82.624192"></trkpt><trkpt lat="49.91403" lon="82.627895"></trkpt><trkpt lat="49.913742" lon="82.627618"></trkpt></trkseg></trk></gpx>

Appear error:

{

    "message": "Sequence is broken for submitted track at time step 13. observation:Observation{point=49.91403,82.627895,0.0}, 8 candidates: [distance: 19.184038033784645 to 49.914136527049614,82.62810575130818,NaN, distance: 18.29446760504956 to 49.91408792481224,82.62813414189738,NaN, distance: 18.29446760504956 to 49.91408792481224,82.62813414189738,NaN, distance: 37.540073141761255 to 49.913730842927045,82.62765201093968,NaN, distance: 39.36651330044647 to 49.91416018243598,82.62840627439518,NaN, distance: 39.36651330044647 to 49.91416018243598,82.62840627439518,NaN, distance: 1.799338939006802 to 49.914018264490984,82.62791230195731,NaN, distance: 1.799338939006802 to 49.914018264490984,82.62791230195731,NaN]. If a match is expected consider increasing max_visited_nodes.",

    "hints": [

        {

            "message": "Sequence is broken for submitted track at time step 13. observation:Observation{point=49.91403,82.627895,0.0}, 8 candidates: [distance: 19.184038033784645 to 49.914136527049614,82.62810575130818,NaN, distance: 18.29446760504956 to 49.91408792481224,82.62813414189738,NaN, distance: 18.29446760504956 to 49.91408792481224,82.62813414189738,NaN, distance: 37.540073141761255 to 49.913730842927045,82.62765201093968,NaN, distance: 39.36651330044647 to 49.91416018243598,82.62840627439518,NaN, distance: 39.36651330044647 to 49.91416018243598,82.62840627439518,NaN, distance: 1.799338939006802 to 49.914018264490984,82.62791230195731,NaN, distance: 1.799338939006802 to 49.914018264490984,82.62791230195731,NaN]. If a match is expected consider increasing max_visited_nodes.",

            "details": "java.lang.IllegalArgumentException"

        }

    ]

}

If I change gps_accuracy to 100, there is no error. But I need gps_accuracy=40.
Before any changes queries like this have been success and everything is ok.

What should I make with it to stay turn restrictions enabled and avoid this error?

Did you try what is written in the error message: consider increasing max_visited_nodes?
Also this does not seem to be necessarily related to ‘changing the data/profile’. You can exclude this by deleting the graph folder (name-gh) and running a fresh import.

Powered by Discourse