GraphHopper.com | Forum | GitHub | Maps | Blog

Can't build/run the iOS application


#1

Hi,

I have been trying to Build the iOS application I cloned from https://github.com/graphhopper/graphhopper-ios it initially downloaded j2objc and then proceeded to build and encountered an error

make: *** No rule to make target 'graphhopper/core/src/main/java/com/graphhopper/apache/commons/collections/IntDoubleBinaryHeap.java', needed by src/.translate_mark'. Stop.

I am not able to proceed further, can anyone please help me to sort this out?

Thanks.


#2

We are in the process of updating the iOS port, but we hit some problems so you should use the previous 0.8.2 version.

See commands here: https://github.com/graphhopper/graphhopper-ios/issues/20#issuecomment-315815128


#3

Thanks…

It seems git checkout 0.8.2 doesn’t work, instead git checkout -b 0.8.2 worked for me.

I have a question do we have to import sample .obf file in our projects? or, it is optional?

Thanks.


#4

The branch names can be only 0.8 or 0.10 not 0.8.2

IF you call -b 0.8.2 you’ll create a new branch from the current commit which won’t work in several cases.


#5

Yes Thanks for the Help, it works now.