Cannot find point (wheelchair routing)

Hi!

I’m running gh 1.0-pre13 to fascilitate wheelchair routing. For the following request

http://s7.thalon.me:8989/maps/?point=Brunnenstraße%2011a%20Höhr-Grenzhausen&point=Kirchstr.%20Höhr-Grenzhausen&locale=de-DE&vehicle=wheelchair&weighting=fastest&elevation=true&use_miles=false&layer=Omniscale

I get:

Cannot find point 0: 50.439114,7.655696
Cannot find point 1: 50.438526,7.656077

That happens for a lot of points…

Bike2 and foot routing works for the two points. How can I check what’s going wrong and maybe solve the issue?

It seems this works now?

The issues with “Cannot find point” often means that the entire area is either disconnected from the rest of the road network or inaccessible somehow. This can be because of certain roads are not accessible for wheelchair or some node barriers are in place. Hard to give a general rule to find the issues.

Yes I changed a bit of code in the WheelchairFlagEncoder and now it works on my GH instance. Basically I removed some restrictions like excluding cobblestones and others which were too strict from my point of view and raised the max slope limit to 15%. The changes are very rudimentary (commenting out lines and replacing 6 with 15 ) and rather suboptimal in a way so that there is a lot of room for improvement. For example it would be better to give a speed penalty to bad surfaces. Unfortunally I didn’t have time and knowledge yet to implement that, but at least I wrote some code reviews in regards to this on GitHub. Maybe we can continue working on that topic there. I would be very happy about that and will look more deeply into the matter myself next year. For now Guten Rutsch!

1 Like
Powered by Discourse