Strange routing on foot=yes path

I observe a very strange routing on a path with foot=yes set:

Visual routing result is this:

the respective GH log output is

2016-05-12 11:07:48,100 [qtp1508269304-32] INFO com.graphhopper.http.GHBaseServlet - weighting=shortest&vehicle=foot&locale=de&point=47.69479190025941%2C11.906087452798335&point=47.69252434322466%2C11.903426701456135 en_US Apache-HttpClient/4.1.1 (java 1.5) [47.69479190025941,11.906087452798335, 47.69252434322466,11.903426701456135], took:0.089038946, , shortest, foot, alternatives: 1, distance0: 39.63634041681248, time0: 1min, points0: 3, debugInfo: idLookup:0.049057733s; , algoInit:0.004194334s, dijkstrabiCH-routing:0.016285792s, extract time:3.722E-6;, algoInit:0.004194334s, dijkstrabiCH-routing:0.016285792s, extract time:3.722E-6, simplify (3->3)

and the GH 0.6 DB is built with

Any ideas?

1 Like

It looks like the subnetwork post-processing removed this way (and probably some more) due to disconnecting issues.

Maybe there is a ford in between - can you please try:


There is no ford in between (i.e. on the way I’m test routing on in the above example), but there are 2 fords in the vicinity… Built with blockFords=false on foot now (I had assumed this flag was for all vehicle so far…) and now the routing is fine.


1 Like

This seems not to work anymore. The following error has been displayed:
Error in custom provider, java.lang.IllegalArgumentException: Since 0.7 EncodingManager does no longer accept upper case profiles: car|blockFords=false,foot|blockFords=false

So I changed it to lowercase:

But it didn’t work either, so I’m wasn’t able to make route through ford or between two fords. How can I fix this?

Oh, finally I’ve figured out how to do this. The correct flag is block_fords now.

1 Like