GraphHopper.com | Forum | GitHub | Maps | Blog

Start Graphhopper Server from Pre-built Graph


#1

Hi,

I’m having trouble starting Graphhopper from a Graph that has been built on another server - I get the error message " Your specified OSM file does not exist D:\OSM\planet-20180906.osm.pbf".

The message is correct in that the PBF file does not exist, but the Graph does and I have successfully started Graphhopper before with a different pre-built Graph, without needing the PBF as well.

The command I’m using is:

java -jar -Xmx50000m -Xms50000m C:\Graphhopper\graphhopper-web-0.10.0-with-dep.jar jetty.resourcebase=webapp config=C:\Graphhopper\config-plotaroute.properties datareader.file=D:\OSM\planet-20180906.osm.pbf

The Graph exists in D:\OSM\planet-20180906.osm-gh\ but when I run the command it seems to try to build the Graph again from the non-existent PBF file.

Is there some variation of the java command that asks it to use the pre-built Graph rather than search for a PBF file?

Thanks,

John


#2

Not sure what goes wrong, but you can try to specify the graph location directly with:
graph.location=graph-gh


#3

That worked! Thanks for your help.

John