Shortest Weighting

I tried to use the shortest weighting but I’m receiving this error.

No weighting found for request {weighting=shortest, instructions=false}, encoder:car, {fastest|car=prepare|CH|dijkstrabi, fastest|bike=prepare|CH|dijkstrabi, fastest|foot=prepare|CH|dijkstrabi}

Maybe this have to do in importing my area together with the settings.
How can i activate the shortest weighting? thanks.

Btw. I am doing this in my android application.

If you want the shortest and fastest weighting with the CH mode you can do in 0.6:


what is CH?
Im using 0.6Snapshot.

My project is 3months old and I want to update to use shortest and fastest,
I almost forgot what settings i should use in using route for bike,walk,car.

Use the settings proposed by @karussell or disable CH. prepare.chWeightings=no

where I can edit those settings? thanks.

Check the properties file which can be used in graphs creation.


thanks. so i just have to add this line in properties.


I received this error…

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] GraphHopper Parent Project … SUCCESS [ 0.774 s]
[INFO] GraphHopper Tools LGPL licensed … SUCCESS [02:39 min]
[INFO] GraphHopper … FAILURE [03:14 min]
[INFO] GraphHopper Tools … SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 05:55 min
[INFO] Finished at: 2016-01-30T21:01:22+08:00
[INFO] Final Memory: 16M/160M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project graphhopper: Could not resolve depende ncies for project com.graphhopper:graphhopper:jar:0.7-SNAPSHOT: Could not transf er artifact org.slf4j:slf4j-api:jar:1.7.13 from/to central (https://repo.maven.a Connection reset -> [Help 1]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit ch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] For more information about the errors and possible solutions, please rea d the following articles:
[ERROR] [Help 1] lutionException
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR] mvn -rf :graphhopper

slf4j-api is available in maven central

Are you using a proxy?

problem solved thank you. :slight_smile:
The problem is with my internet. Slow connection probably. thanks.

I had same trouble. I solved. Thanks !!! :flashlight:

Me too.
I’m trying to create custom weighting on android device.
But I met the problem -
{An error happened while retrieving maps: Configured[shortest|car] is not equal to loaded [fastest|car]}
is any one know how to solve this problem?


That usually means that should use the same options when creating a routing graph and then trying to load it.