Server.application_connectors - Could not resolve type id 'http'

Hi,

i just setup my ide und could build the project.
but when i start the web-server i get the following error:

Failed to parse configuration at: server.application_connectors.[0]; Could not resolve type id ‘http’ as a subtype of io.dropwizard.jetty.ConnectorFactory: known type ids = []

the same config-file using the pre-build jar from https://graphhopper.com/public/releases works without any problems.

what’s my mistake?

here are my config- and custom-profile-files:
config-austria.yml.txt (10.7 KB)
car-f.yml.txt (22 Bytes)
car-sf.yml.txt (23 Bytes)

(files are just renamed to *.txt for upload)

Not sure. Never saw such an issue. Are you using GraphHopper in a custom project then your pom.xml might not be correctly set up: https://github.com/dropwizard/dropwizard/issues/455

no, i didn’t create a special custom project.

i use the newest version of IntelliJ Idea.
created a project from git using “https://github.com/graphhopper/graphhopper.git
and built the jar for graphhopper-web.
no extra code.
the only thing i changed:
i moved the generated META-INF directory from directory “java” to “resources” as otherwise the generated jar even couln’t be executed.

i don’t know, if it’s a clean solution,
but i found a solution, that solved my problem.
as graphhopper.sh do not work on win10 (at least on my computer)
i looked for the maven statement in graphhopper.sh

then i executed the command
“C:\Program Files\JetBrains\IntelliJ IDEA\plugins\maven\lib\maven3\bin\mvn.cmd” --projects web -am -DskipTests=true package
that statement created a correct working jar.

so i added a pre-task (Run Maven Goal) in my run-configuration
command parameter: --projects web -am -DskipTests=true package

i don’t know, if this is a good solution.
but at least this works for me.

if there exists a better solution, please tell me.

Powered by Discourse