GraphHopper.com | Forum | GitHub | Maps | Blog

Local Server java.lang.IllegalStateException: Cannot load properties to fetch EncodingManager


#1

Hello!

I tried to set up my own Graphhopper Server using Ubuntu 16.04… I already managed to do so, a couple of months ago and documented my steps. I used the same commands as the last time, but unfortunately I get a exception when I type: ./graphhopper.sh web europe_austria.pbf.

The exception is:
Exception in thread “main” java.lang.IllegalStateException: Cannot load properties to fetch EncodingManager configuration at: ./europe_austria-gh/
at com.graphhopper.routing.util.EncodingManager.create(EncodingManager.java:155)
at com.graphhopper.GraphHopper.load(GraphHopper.java:726)
at com.graphhopper.GraphHopper.importOrLoad(GraphHopper.java:618)
at com.graphhopper.http.GraphHopperModule$2.start(GraphHopperModule.java:156)
at com.graphhopper.http.GHServer.start(GHServer.java:123)
at com.graphhopper.http.GHServer.start(GHServer.java:63)
at com.graphhopper.http.GHServer.main(GHServer.java:58)

Maybe the last change in git caused this issue?


#2

What is the content of europe-austria-gh? If it just contains a lock file you can remove it and try again.


#3

There is no content in europe_austria-gh


#4

Try removing it. Normally it should not fail this way but it looks like it has problems with this empty directory


#5

I tried again from scratch and now everything is working fine. Thank you for your time. :wink: