Issues building android app

I have a previously working number of projects using the graphhopper routing engine snapshot 2 on android.
I have copied these files to a new dev environment
graphhopper core2 snapshot jar actually exists in project folder/graphhopper-master/core/target (probably from a previous build on another dev env) but upon build I get the error " Failed to resolve: com,graphopper: graphopper-core:2.0-SNAPSHOT.
This also applies to 1.0 snapshot. Those files appear to be missing from the online repositories. Has anyone had similar issues, I have to assume its the setup rather than the project as it used to work.
I have tried to import the entire project, build from both local and external sources, same error
Any suggestions appreciated

Did you try using versions 2.0, or 2.4 for example? The snapshot versions aren’t available on Maven Central.

1 Like

Btw the most recent version is 6.2.

Thanks :blush:, will try.

Thanks for this, for some reason its still building with snapshot 2 ,the map works with android 8 but not 10. (No errors given in android studio for andoid 10) . I will start from scratch with 6.2 in a new project as im only using offline routing as a fallback when offline. I notice the pbf files have increased in size from a year ago ( from 180mb to 1.8G ) so looking for a way to minimise those.

The OSM files increase every year, maybe like 10-20%, but not that much(?)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.