Is "avoid" still not supported in open source version of GH?

Hi,

A while back I asked a question in another thread about using the “avoid” parameter in routing requests on a self-hosted solution.

We added “routing.ch.disabling_allowed=true” to our config file and “&ch.disable=true&avoid=motorway” to our requests but it didn’t have any effect.

At the time you said:

“Sorry, I forgot that this feature is currently only implemented in our EE service (not really to hide it to make money, but to hide it as it is a bit ugly and we don’t want to support that in our open source software, where we plan a better infrastructure for these features).”

Is it still the case that the “avoid” parameter can’t be used with the self-hosted solution?

Thanks.

There is no such parameter but the feature is already there. See the new customizable routing feature:

Wow, that looks great, so much flexibility. I hadn’t spotted the announcement about the new version amidst all the coronavirus distractions. Just need to get my head around how it works now and what implementation entails. Many thanks.

1 Like

I’ve started to experiment with various profile settings using your demo server, but I’ve hit a snag, which I think may be an old issue. In the following example, I am trying to route By Bike from a Service Road (asphalt), via a Path (ground), to a Bridle Path (ground). It reaches the Path but won’t go onto the Bridle Path. The Bridle Path has Allowed Access for Bicycles set to Yes on OSM and also has a bicycles tag set to yes.

http://148.251.46.152:8989/maps/?point=51.26121%2C-0.441881&point=51.258966%2C-0.442021&locale=en-US&elevation=true&profile=bike&use_miles=false&layer=OpenStreetMap

If I change the vehicle to Foot it works OK and if I then add the following custom profile while still using Foot it correctly prevents routing over the Path and Bridle Path.

priority:
surface: {
ground: 0.0
}

There just seems to be an issue with Bike routing over the Bridle Path even though cycling is explicitly allowed.

I don’t think it is related to the customizable routing feature. This could be just a bug. If you can reproduce this in a test (see e.g. BikeFlagEncoderTest) I try to fix this fast.

I’m not sure what you need (I don’t know what BikeFlagEncoderTest is). You can see the issue here:

https://graphhopper.com/maps/?point=51.26121%2C-0.441881&point=51.258966%2C-0.442021&locale=en-us&vehicle=bike&weighting=fastest&elevation=true&turn_costs=false&use_miles=false&layer=Omniscale

It won’t route all the way to the finish marker, despite the Bridle Path having explicit Access permissions for cycling. Let me know if you need anything further.

Did you manage to find out the cause of the Bike routing problem? I’ve done some further tests and it seems that Bike routing fails on all Bridle Paths where Allowed Access for Bicycles = yes. That seems like quite a major bug, as we have over 32,000km of bridleway in the UK alone, where cycling is permitted. Any idea when it can be fixed? I don’t have any java expertise, so can’t help with that side of things, but let me know if you need more examples.

See this PR https://github.com/graphhopper/graphhopper/pull/2105 from @ratrun

Powered by Discourse