Incorrect route through intersection

Thanks for developing Graphhopper! I just wanted to report a slightly incorrect route:

https://graphhopper.com/maps/?point=57.543612%2C67.187051&point=57.545546%2C67.188134&locale=ru-RU&elevation=true&profile=car&use_miles=false&selected_detail=Elevation&layer=OpenStreetMap

FWIW, in looking at the intersection itself, it seems that the turn shown above is not allowed, so I added a turn restriction. If Graphhopper respects that, which I suppose it will, then it should start routing correctly soon.

2 Likes

Thanks

It does, but only if turn_costs: true is enabled for the profile you use.

So if you don’t enable that option, it routes you through known-illegal turns? Hopefully that option is enabled by default…

Yes. And yes, it is enabled by default on graphhopper.com/maps. It is not enabled by default in config-example.yml though, but there is a commented out profile called car_with_turn_costs.

@jfriedl yes, as answered @easbar the turn costs is enable on graphhopper.com

I want to note that without turning, it also builds a route pretty well, and turning on will increase map importing time.
Generally, this doesn’t affect to request processing time. But it greatly increases processing time of requests with custom model for LM profiles.

@easbar I noticed that the route is now building correctly (probably in CH mode), but with custom model (LM mode) builds as before (slightly incorrect).

Powered by Discourse