I Can Not Open Demo App with Android Studio

I followed structions mentioned here for Android Studio.
but I face this error!

Help me please!


thanks for your message. This seems to be caused by this issue. Maybe one of the solutions described by @devemux86 in this issue might help you.


That issue is more about failed Gradle build command, the Sample still should run from within Android Studio on emulator or a device.
Or else we had seen that earlier and fixed it. :slight_smile:

Do you use the latest Android Studio and Gradle releases (not beta)?
Should be Android Studio 2.3.3 and Gradle 3.3.

I am using Android Studio 2.3.3 and gradle 2.3.3, when I changed gradle to 3.3 I face error:
Error:Could not find com.android.tools.build:gradle:3.3.

That’s Android Gradle plugin, it’s correct to be 2.3.3.

So what’s the problem?

Can you try with latest master?

Sure, but exactly the same error

Can you to change

compileSdkVersion 26
buildToolsVersion “26.0.1”


compileSdkVersion 25
buildToolsVersion “25.0.0”

in the build.gradle and also install the older SDK and build tools via the sdkmanager? For me this was necessary to avoid this strange SimException, see my comment here

Thanks it works!!!

1 Like

This is good but bad at the same time. I thought it was just a misconfiguration on my side but now it seems to be more likely. We’ll have to keep an eye on this.

That’s strange, just retested latest master and runs fine with 26.0.1, even building like:

./gradlew clean build


./gradlew clean assembleRelease

BTW build tools 25.0.0 is very old, have you tried with latest 25.0.3 in the series?

I tried with build tools 25.0.0 but 25.0.2 was ok too.

yes, as you told me, I download again the last master, but I face the same error!