GraphHopper.com | Forum | GitHub | Maps | Blog

How to change "flexible mode"?


#1

I use “java -Xmx2g -Xms2g -Dgraphhopper.datareader.file=bj8.osm -jar graphhopper-web-0.12-SNAPSHOT.jar server config-example.yml” to open my service, but i want to try “flexible mode”,so how to change the config.yml ,please tell me ,thanks


#2

in config.yml uncomment

# routing.ch.disabling_allowed: true

now you can add &ch.disable=true to your URL to disable CH routing


#3

Thanks,but if I uncomment the “# routing.ch.disabling_allowed: true”
the service can’t open, May I ask if there are any other changes I need to make?
image


#4

well, looks like you haven’t just uncommented the ch disabling line but done something else to config.yaml and now the file can’t be parsed anymore


#5

It’s my faul.Just one more space,but when I change the parameter “routing.non_ch.max_waypoint_distance: 5” It seems doesn’t work,I want the result could callback more way_points,Do you know how to modify it,Thank you very much.


#6

The parameter “routing.non_ch.max_waypoint_distance:” means the distance between the start point and the end points? Oh,so how can I make the number of result points increasing,for example per 1 meter 1 points,I’m crazy…