Failed to download com.conveyal.jackson2-geojson.jar 0.8 from

Dear all

When I tried to download all dependencies and run the graphhopper program, I got following error:

[ERROR] Failed to execute goal on project graphhopper-reader-gtfs: Could not resolve dependencies for project com.graphhopper:graphhopper-reader-gtfs:jar:0.10-SNAPSHOT: Failed to collect dependencies at com.conveyal:gtfs-lib:jar:2.1.0 -> com.conveyal:jackson2-geojson:jar:0.8: Failed to read artifact descriptor for com.conveyal:jackson2-geojson:jar:0.8: Could not transfer artifact com.conveyal:jackson2-geojson:pom:0.8 from/to conveyal ( Received fatal alert: handshake_failure -> [Help 1]

I tried to access and got ‘Access Denies’ message.

Can anyone share this jar with me or tell me where I can download this jar ?

Thanks a lot

This might be a maven problem and also the repo does not seem to be necessary. Can you try to update maven to the latest 3.5.0?

If you use the scripted way for installation try:

rm -rf maven
wget -O
mv apache-maven-3.5.0 maven

Or other question: which maven version and java version do you have installed?

Thanks a lot. The problem was solved.
Previously, I am using maven 3.2.3. After I changed to maven 3.5 and jdk1.8, the server can be started.

1 Like