GraphHopper.com | Forum | GitHub | Maps | Blog

Errors (that apparently shouldn't happen) are happening in graphhopper.sh measurement


#1

Hi,

I’m running the measurement tool over graphhopper data that I imported.

My import was using these config.properties:

graph.flag_encoders=car|turn_costs=true
prepare.ch.weightings=no
prepare.lm.weightings=fastest
prepare.min_network_size=200
prepare.min_one_way_network_size=200
routing.non_ch.max_waypoint_distance = 1000000
graph.dataaccess=RAM_STORE

When I first ran the measurement tool, I got a Java Exception because the graphhopper.sh measurement tool was overwriting my config.properties graph.flag_encoders setting, and setting it to “car” instead of “car|turn_costs=true”. I removed all the overwritten configuration properties in the graphhopper.sh file, so that it would work from my config.properties file, and so it now would run!

JAVA_OPTS="-Xmx30000m -Xms30000m -server" ./graphhopper.sh measurement /path/to/map.osm.pbf

However, I’m getting a lot of errors, perhaps about 20 per second. They look like this:

2017-12-20 09:59:48,141 [main] ERROR com.graphhopper.tools.Measurement$8 - errors should NOT happen in Measurement! -43.589193603154875,172.38357415162565; 52.121747146287866,-3.5735710391455378 => [com.graphhopper.util.exceptions.PointDistanceExceededException: Point 1 is too far from Point 0: 52.121747146287866,-3.5735710391455378]

The message says that “errors should NOT happen in Measurement!” and so I’m now concerned that my imported data is corrupted somehow.

Is that the case? Is there any clue I can be given about what to do to prevent this corruption?

Thanks
Luke


#2

If you set the limit

routing.non_ch.max_waypoint_distance = 1000000

Then you’ll get errors in measurement if there are routes longer than this. This is kind of expected and data is ok IMO


#3

Thank you so much for your quick reply!

I’ve just had that setting explained in this post so that makes sense to me.

Cheers,
Luke