Entry in encoder list not supported: PT

I took the instruction from here: https://github.com/graphhopper/graphhopper/tree/master/reader-gtfs and tried to merge it into docker-compose.

In Dockerfile, nothing has changed, since the -D options from the PT example go into docker-compose.yml, overinging environment variables, and they get into command line correctly (see below).

I got the osm.pbf and gfts files of Germany/Brandenburg, as in the example. But Graphhopper says "vehicle pt not supported":

gr    | ## now web. JAVA_OPTS=-server -Xconcurrentio -Xmx1g -Xms1g -XX:+UseG1GC -XX:MetaspaceSize=100M 	-Dgraphhopper.datareader.file=/data/data.osm.pbf 	-Dgraphhopper.gtfs.file=/data/gtfs-vbb.zip 	-Dgraphhopper.graph.flag_encoders=pt 	-Dgraphhopper.prepare.ch.weightings=no 	-Dgraphhopper.graph.location=./graph-cache 
gr    | 2018-05-28 21:44:25,332 [main] INFO  com.graphhopper.http.CmdArgsModule - jsonp disabled
gr    | Exception in thread "main" com.google.inject.ProvisionException: Unable to provision, see the following errors:
gr    | 
gr    | 1) Error in custom provider, java.lang.IllegalArgumentException: entry in encoder list not supported pt

(JAVA_OPTS has this line like in the example: graphhopper.graph.flag_encoders=pt)
Error message is: entry in encoder list not supported pt

I looked through the docs in reader-gtfs folder, but did not find anything that I could have missed. Should I build graphhopper with more options?

I ran the code on 0.10 branch.

In the other issues & threads, I found out that you have to use reader-gtfs class instead of the usual.

I edited graphhopper.sh to change /web/ to /reader-gtfs/ and see if it will work.

Added this section and called it from Dockerfile:

elif [ "$ACTION" = "buildgtfs" ]; then
 execMvn --projects reader-gtfs -am -DskipTests=true package

Then edited “web” action, swapping every /web path. Unfortunately, this didn’t work.

$ graphhopper.sh web
Error: Unable to access jarfile ./reader-gtfs/target/graphhopper-web-0.10-SNAPSHOT-with-dep.jar

Updated to master tip, and got the paths right. Now the path is found, but this jar won’t work

no main manifest attribute, in reader-gtfs/target/graphhopper-reader-gtfs-0.11-SNAPSHOT.jar

After reading some docs, I see it’s just a module (which is mentioned in pom.xml). But how do I make it load?

Turned out the older version (0.10) does not have this feature or it’s not functional there. Tip of master branch (0.11 snapshot) worked.