Dockerfile/docker-compose not working properly

I tried running graphhopper in docker, and several things are out of sync:

  1. Dockerfile has command buildweb which is absent in Should I change it to simply build web?

I checked out the tag 0.10.0, and tried building/running that version, but

  1. When running the container, maven is not installed and fails to build GH. When I run docker-compose up, I see logs:

    gr | ./ line 86: mvn: command not found
    gr | ## using existing osm file /data/data.osm.pbf
    gr | ## building graphhopper jar: tools/target/graphhopper-tools-0.10-SNAPSHOT-jar-with-
    gr | ## using maven at ./maven
    gr | ## compilation of parent failed
    gr | [INFO] Scanning for projects…
    gr | [INFO] ------------------------------------------------------------------------
    gr | [INFO] Reactor Build Order:
    gr | … Failed to read artifact descriptor for org.apache.maven.plugins:maven-assembly-plugin:jar:3.0.0

Not sure what is going wrong here.

The building problem solved with network_mode: "bridge" in docker-compose file.

1 Like

Thanks. Although this is strange as it should be the default: