GraphHopper.com | Forum | GitHub | Maps | Blog

Direction around roundabout


#1

Hi guys, I am new to working with map-matching and have looked at getting matching some bike gps pings to produce a matched patch.

Everything seems to be working well when I adjust the GPS accuracy to suit and the matched paths seem to be realistic based on our data and map.

However, there does not seem to be a way of setting the direction that the matched path takes around roundabouts. i.e. sometimes it goes clockwise, sometimes anti-clockwise. We are in the UK and most of the time we need the path to be clockwise. I think the algorithm just fits the shortest path around the roundabout, but is there any way of forcing a clockwise direction around roundabouts?

Thanks for any help!


#2

Currently you cannot go into the opposite direction of the allowed direction, except of course for the foot profile. You could disable direction for roundabouts or implement a preference but there is nothing out of the box and disabling direction in general can lead to worse matching results.


#3

Thanks for replying, so I am guessing the tracks that I have obtained for the “bike” profile the direction logic at present is the same as the “foot” profile. The bike matched routes I have obtained seemed to go either side of the roundabout and I think it is the shortest route.

I need to enable the direction logic for bikes on roundabouts, but also allow tracks to go on paths for bikes - so cannot just use the “car” profile. Is this something the “bike” profile should do anyway?

I was thinking that the directions were obtained from the OSM pbf file that I am using, again I am new to all this so excuse my ignorance!


#4

Is this something the “bike” profile should do anyway?

Yes, all bike profiles should consider the direction of the road. Opposite direction is currently not allowed (although we could with walking speed)

Can you check openstreetmap.org and the roundabout data (click edit)?


#5

Thanks for all your quick replies, on further investigation I had mixed up the direction of the path! Sorry my mistake, I had zoomed in on specific sections and didn’t not notice the start and end point. Everything is working as it should!